User manual

Implementation architecture

Fig. 14 shows the system architecture of MR3 from the aspect of system implementation. MR3 is implemented in Java language, using the Java Swing user interface. MR3 uses JGraph for RDF(S) graph visualization, and Apache Jena for enabling the use of Semantic Web standards such as RDF, RDFS, and OWL. The Parser and Generator in MR3 are implemented using Jena APIs. By using these libraries, MR3 is implemented as an environment for graphical representation of Semantic Web descriptions.

Implementation architecture of |MR3|

Fig. 14 Implementation architecture of MR3

System overview

Fig. 15 shows the system overview of MR3 . MR3 consists of the Parser, Generator, RDF(S) Management, and Graphical Modeler. The Graphical Modeler mainly consists of the RDF Editor, Class Editor, and Property Editor. The user edits the RDFs description visually via the Graphical Modeler. The input and output of MR3 are RDFs documents. The Parser analyzes input RDFs documents and makes further operations possible by transforming the RDFs document into a Jena model. Then, the Parser changes the Jena model into an internal data expression, and RDF(S) management is performed. The Generator changes the internal data expression into a Jena model. Finally, the Jena model is changed into an RDFs document.

System overview of |MR3|

Fig. 15 System overview of MR3

Overview of the Graphical Modeler

Fig. 16 shows a typical screen showing the Graphical Modeler of MR3 . The Graphical Modeler consists of RDF Editor, Class Editor, Property Editor, Attribute Dialog, Namespace Table, Remove Dialog, Find Resource Dialog, Import Dialog, and Export Dialog.

The details of the Graphical Modeler are shown in the following sections.

Typical screen with Graphical Modeler interface of |MR3|

Fig. 16 Typical screen with Graphical Modeler interface of MR3

RDF Editor

The RDF Editor allows the user to express the relationship between an RDF resource, RDF property, and RDF literal using a directed graph, and also allows the attributes of each element to be edited. The attributes of an RDF resource consist of a URI, the URI type, and the RDF resource type. The RDF resource type can be chosen using the Class Editor. The URI type can be chosen from either a URI or can be set as anonymous.

As shown in Fig. 17, RDF resources are represented as ellipses, RDF properties are represented as arrows, and RDF literals are represented as rectangles in the RDF editor. Types of RDF resources are shown at the upper left part of the RDF resources.

RDF Editor

Fig. 17 RDF Editor

Toolbar in the RDF Editor

Icons in the toolbar in the RDF Editor and the corresponding functions are shown in the following table.

Icon Function
_images/resource.png
Insert an RDF resource
_images/literal.png
Insert an RDF literal
_images/copy.png
Copy nodes
_images/cut.png
Cut nodes
_images/paste.png
Paste nodes
_images/delete.png
Remove nodes
_images/undo.png
Undo
_images/redo.png
Redo
_images/export_graph_img.png
Save the RDF graph as image file
_images/l_to_r_layout.png
Automatically layout the RDF graph
_images/open_resource.png
Open a selected RDF resource

Editing attributes of RDF resources

When users select an RDF resource in the RDF Editor*, the attributes of the RDF resource are shown in the **Attribute Dialog ( Fig. 20 to Fig. 25 ). The attributes of RDF resources are URI, rdf:type, blank node or not, rdfs:label, and rdfs:comment. Here the blank nodes are RDF resources that are not named by URIs. Blank nodes can not be acceced from external documents. However, the blank nodes can be subjects or objects of statements. They are used to represent RDF resources that are difficult to name or structure RDF contents.

If users would like to set a URI of an RDF resource, they should select URI from the left side menus in the Attribute Dialog as shown in Fig. 20. Prefixes that are registered in the Namespace Table are shown in the [Prefix] combo box. When users select one of the prefixes in the combo box, the corresponding namespace is shown in the [RDF Resource] text field. The users can input any URI in the text field. If the users would like to set an RDF resource as a blank node, the users should check the [blank node] checkbox.

Attribute Dialog (URI of an RDF resource)

Fig. 20 Attribute Dialog (URI of an RDF resource)

If the users would like to set a type to an RDF resource, the users should select the [Resource Type] from the left side menu in the Attribute Dialog as shown in Fig. 21. The [Resource Type] checkbox should be checked when the users input the type of an RDF resource. If the users would like to empty the type of an RDF resource, they should uncheck the [Resouce Type] checkbox.

When the users click the [Select Type] button, [Select Resource Type Dialog] are shown as shown in Fig. 22. The class hierarchy that is build in the Class Editor is shown in the [Select Resource Type Dialog]. When the users select an RDFS class in the dialog, the namespace and ID of the selected class are set in the Attribute Dialog.

When the users input a URI that is not defined in the [Class Editor], [RDF(S) contents management] dialog is shown as shown in Fig. 23. In the RDF(S) contents management dialog, the users can select Rename or Create.

When the users click the [ClassEdit] button, the type of an RDF resource is selected and the attributes of the type of the RDF resource are shown in the Attribute Dialog.

Attribute Dialog (type of RDF resource)

Fig. 21 Attribute Dialog (type of RDF resource)

RDF Resource Type Selection Dialog

Fig. 22 RDF Resource Type Selection Dialog

RDF(S) contents management dialog

Fig. 23 RDF(S) contents management dialog

If the users would like to define the rdfs:label of an RDF resource, the users should select [Label] in the left side menu in the Attribute Dialog as shown in Fig. 24. After inputting language in the [Lang] text field and label in the [Label] text field, the language and the label are added in the table in the Attribute Dialog. If the users select a line in the table and click Remove button, the selected label is removed.

Attribute Dialog (Label of an RDF resource)

Fig. 24 Attribute Dialog (Label of an RDF resource)

If the users would like to define the rdfs:comment of an RDF resource, the users should select [Comment] in the left side menu in the Attribute Dialog as shown in Fig. 25. After clicking the [Add] button, the [Edit Comment Dialog] is shown.

First input language in the [Lang] text field and comment in the [Comment] text area. Then, click [OK] button. After that, the language and the label are added in the table in the Attribute Dialog. If the users select a line in the table and click [Edit] button, the users can edit the selected comment and the language. In the same way, if the user select a line in the table and click [Remove] button, the selected label is removed.

Attribute Dialog (Comment of an RDF resource)

Fig. 25 Attribute Dialog (Comment of an RDF resource)

Editing attributes of RDF properties

If the users select an RDF property in the RDF Editor, the attributes of the RDF property are shown in the Attribute Dialog (Fig. 26). The users can edit the URI of the selected RDF property.

When the users input a URI which is not defined in the Property Editor, [RDF(S) contents management] dialog is shown as shown in Fig. 23. In the [RDF(S) contents management] dialog, the users can select rename the RDFS property or create an RDFS property.

When the users select one of the prefixes in the dialog, IDs of RDFS properties that are defined in the Property Editor and the namespace is correspond to the selected prefix are shown in the [Property ID] list.

When the users select one of the Property IDs and click [RDFSPropertyEdit] button, the RDFS property is selected and the attributes of the RDFS property are shown in the Attribute Dialog.

Attribute Dialog (RDF Property)

Fig. 26 Attribute Dialog (RDF Property)

Editing attributes of RDF literals

When the users select an RDF literal in the RDF Editor, the attributes of the RDF literal are shown in the Attribute Dialog. (Fig. 27) The users can edit the contents of the literal, the attribute of language (xml:lang), and the data type of the literal. In the [Literal] text are, the users can input the contents of the literal. The users can also input language in the [Lang] text field. If the users set the data type of the literal, the users should check [Data type] checkbox and select one of the types in the combobox. Language attribute and data type attribute are exclusive and the users only select one of them.

Attribute Dialog (RDF Literal)

Fig. 27 Attribute Dialog (RDF Literal)

Class Editor

The Class Editor allows the users to edit the attributes of RDFS classes and the relationships between the classes.

Fig. 28 shows a screenshot of the Class Editor.

A screenshot of the Class Editor

Fig. 28 A screenshot of the Class Editor

Toolbar in the Class Editor

Icons in the toolbar in the Class Editor and the corresponding functions are shown in the following table.

Icon Function
_images/resource.png
Insert an RDFS class
_images/copy.png
Copy nodes
_images/cut.png
Cut nodes
_images/paste.png
Paste nodes
_images/delete.png
Remove nodes
_images/undo.png
Undo
_images/redo.png
Redo
_images/export_graph_img.png
Save the class graph as an image file
_images/l_to_r_layout.png
Automatically layout the class graph (lef to right)
_images/u_to_d_layout.png
Automatically layout the class graph (up to down)
_images/open_resource.png
Open a selected RDFS class

Editing attributes of the Class editor

When the users select an RDFS class in the Class Editor, the attributes of the RDFS class are shown in the Attribute Dialog (Fig. 31 to Fig. 33). The users can edit the attributes of an RDFS class by selecting Base, Label, Comment, Instances, or SuperClasses items from the left side menu in the Attribute Dialog.

When the users select the [Base] item, the type of an RDFS class and the URI can be edited (Fig. 31). The [Resource Type] can be defined by [Class Class List] in the Option Dialog. When the users select the [Label] item, the value of rdfs:label property can be edited. When the users select the [Comment] item, the value of rdfs:comment property can be edited. The methods for editing rdfs:label and rdfs:comment are same as RDF resource. When the users select the [Instances] item, the instances of the selected RDFS class are shown in the list (Fig. 32). When the users select the one of the items in the list, corresponding RDF resource is selected and the attributes of the RDF resource are shown in the Attribute Dialog. When the users select the *[SuperClasses] item, the super classes of the selected RDFS class are shown in the list (Fig. 33).

Attribute Dialog (Base of RDFS class)

Fig. 31 Attribute Dialog (Base of RDFS class)

Attribute Dialog (Instances of the RDFS class)

Fig. 32 Attribute Dialog (Instances of the RDFS class)

Attribute Dialog (Upper classes of the RDFS class)

Fig. 33 Attribute Dialog (Super classes of the RDFS class)

Property Editor

The Property Editor allows the users to edit the attributes of RDFS properties and the relationships between the properties.

Fig. 34 shows a screenshot of the Property Editor.

A screenshot of the Property Editor

Fig. 34 A screenshot of the Property Editor

Toolbar in the Property Editor

Icons in the toolbar in the Property Editor and the corresponding functions are shown in the following table.

Icon Function
_images/resource.png
Insert an RDFS property
_images/copy.png
Copy nodes
_images/cut.png
Cut nodes
_images/paste.png
Paste nodes
_images/delete.png
Remove nodes
_images/undo.png
Undo
_images/redo.png
Redo
_images/export_graph_img.png
Save the property graph as an image file
_images/l_to_r_layout.png
Automatically layout the RDFS property graph (left to right)
_images/u_to_d_layout.png
Automatically layout the RDFS property graph (up to down)
_images/open_resource.png
Open a selected RDFS property

Editing attributes of the Property editor

When the users select an RDFS property in the Property Editor, the attributes of the RDFS property are shown in the Attribute Dialog (Fig. 37 and Fig. 38). The users can edit the attributes of an RDFS property by selecting [Base], [Label], [Comment], [Domain/Range], [Instances], or [SuperProperties] items in the left side menu of the Attribute Dialog. [Base], [Label], and [Comment] items are same as RDFS Class. The [Resource Type] list in the [Base] item can be defined by the [Property Class List] in the Option Dialog. When the users select [Domain/Range] item, domains and ranges of the selected RDFS property can be edited (Fig. 37). When the users select [Instances] item, RDF resource list that have the selected RDFS property is shown in the Attribute Dialog (Fig. 38). When the users select the one of the items in the list, the RDF resource is selected and the attributes of the RDF resource are shown in the Attribute Dialog. When the users select [SuperProperties] item, super properties of the selected RDFS property are shown in the list.

Attribute Dialog (Rnage of RDFS property)

Fig. 37 Attribute Dialog (Range of RDFS property)

Attribute Dialog (Instances of RDFS property)

Fig. 38 Attribute Dialog (Instances of RDFS property)

Resource Search Dialog

The users can find resources (RDF resources, RDF properties, RDFS classes, and RDFS properties) by using Resource Search Dialog. Fig. 39 shows a screenshot of the Resource Search Dialog. When the users enter a string in the [Keyword] text field, the corresponding resource list is displayed in the [Find Result] list at the bottom of Fig. 39. The serach targets are URIs, labels, and comments of RDFS classes, properties, and RDF resources. When the users select the one of the items in the list, corresponding resource is selected and the attributes of the resource are shown in the Attribute Dialog.

A screenshot of the Resource search dialog

Fig. 39 A screenshot of the Resource search dialog

Namespace Table

The users can register perfixes and the corresponding namespaces in the Namespace Table. Fig. 40 shows a screenshot of the Namespace Table. When the users set a prefix in the [Prefix] text field, set a namespace in the [NameSpace] text field, and click [Add] button, the prefix and the namespace are added in the table in the Namespace Table. If the users would like to remove the prefix and the corresponding namespace, select the line in the table and click [Remove] button. If the users check the available checkbox, namespaces of resources in each editor are replaced with the corresponding prefix (This function is only available when the View->URI menu is selected.). When the users set a URI of an resource, the Namespace Table is referred and the users can select the registered prefixes in the Attribute Dialog. When the users select one of the prefixes, the corresponding namespace is shown in the [Namespace] label or [RDF Resource] text field.

A screenshot of the Namespace Table

Fig. 40 A screenshot of the Namespace Table

Remove Dialog

If an RDFS class is referred by a type of a resource or a domain or a range of a property, it is inconsistency when the RDFS class is removed. If an RDFS property is reffered in the RDF editor, it is inconsistency when the RDFS property is removed. In these cases, when the users remove those RDFS classes or properties, the Remove Dialog as shown in Fig. 41 is shown before removing them actually.

Removed RDFS classes or properties are shown in the upper part of Fig. 41. RDF resources that referred the removed RDFS classes as their type are shown in the [RDF Editor] tab in the lower part of Fig. 41. RDF properties that referred the removed RDFS properties are also shown in the [RDF Editor] tab. RDFS properties that refer removed RDFS classes as their domains or ranges are shown in the [Property Editor] tab in the lower part of Fig. 41.

If the users check the [Delete Check] Checkboxes and click [Apply] button, RDF resources, RDF properties, and RDFS properties that listed in the lower part of the Remove Dialog stop referring to the removed RDFS classes or RDFS properties. Then, the RDFS classes and RDFS properties are actually removed.

If the users select one of the RDF resources, RDF properties, or RDFS properties, attributes of the selected resource are shown in the Attribute Dialog. Then, the users can edit the attributes to maintain consistency.

Remove Dialog

Fig. 41 Remove Dialog

Import Dialog

The users can import RDF(S) documents described as Turtle, JSONLD, RDF/XML, N-Triples, or mr3 format to MR3 by using Import Dialog. Fig. 42 shows a screenshot of the Import Dialog. The users can open Import Dialog by clicking [Open] sub menu in the [File] menu or clicking open icon in the Toolbar.

First, select a file that the users want to open. Then, select a file format from the [Files of Type]. Finally, select [Open] button.

A screenshot of the Import Dialog

Fig. 42 A screenshot of the Import Dialog

If the users select [All Files] from the [Files of Type], the file format is automatically detected from the extension of the file. The correspondence between the extension and the file format is shown below.

Extension File format
ttl Turtle
jsonld JSONLD
n3 N-Triples
rdf RDF/XML
mr3 MR^3 project

Export Dialog

The users can export RDF(S) data graphs in MR3 to an RDF(S) document as Turtle, JSONLD, RDF/XML, N-Triples, or mr3 syntax by using the Export Dialog. Fig. 43 shows a screenshot of the Export Dialog. The users can open Export Dialog by clicking [Save As] sub menu in the [File] menu or clicking saveas icon in the Toolbar.

First, select a file that the users want to save. Then, select a file format from the [Files of Type]. Finally, select [Save] button. If the users select [All Files] from the [Files of Type], the file format is automatically detected from the extension of the file.

A screenshot of the Export Dialog

Fig. 43 A screenshot of the Export Dialog

Option Dialog

The users can set configurations about [Base], [Directory], [Proxy], [Meta Class], and [Layout] in the Option Dialog.

Base

When the users select the [Base] item as shown in Fig. 44, language, UI language, base URI, and log file can be set. If a resource has many multilingual labels, the users should select the prior language. The prior language of labels can be set in the [Lang] text field. Labels with prior language are shown in each resource when the user select View->label menu. Language of UI such as menu can be set in the [UILang] combobox. The users can select ja (Japanese), en (English), or zh (Chinsese) from the [UILang] combobox. Default namespace is set based on the [Base URI]. The directory that a log file is saved can be set by clicking [Browse] button and selecting the directory from the directory selection dialog.

Option Dialog: Base

Fig. 44 Option Dialog: Base

Directory

When the users select the [Directory] item as shown in Fig. 45, work directory and resources directory can be set. The work directory is a directory that is opened firstly when the users import an RDF(S) document. The resources directory is a directory that property files are saved. The property files are defined labels that displayed in MR3 for each language.

Option Dialog: Directory

Fig. 45 Option Dialog: Directory

Proxy

When the users select the [Proxy] item as shown in Fig. 46, a host name and a port number of a proxy server can be set. This configuration is necessary to import an RDF(S) document from a URI when the user’s environment is under a proxy server.

Option Dialog: Proxy

Fig. 46 Option Dialog: Proxy

Meta Class

When the users select the [Meta Class] item as shown in Fig. 47, [Class Class] and [Property Class] can be set. If the users set a Class Class, MR3 regards resources that have the Class Class as their type as classes. If the users set a Property Class, MR3 regards resources that have the Property Class as their type as properties. These classes and properties are imported in the Class Editor or Property Editor.

In the initial setting, rdfs:Class is defined in Class Class and rdf:Property is defined in Property Class. If the users would like to import OWL classes and properties, owl:Class must be set as Class Class, owl:ObjectProperty and owl:DatatypeProperty must be set as Property Class.

Option Dialog; Meta Class

Fig. 47 Option Dialog: Meta Class

Layout

When the users select the [Layout] item as shown in Fig. 48, methods for layout for each editor can be set.

Option Dialog: Layout

Fig. 48 Option Dialog: Layout

Validator

When the users select [Validator] sub menu in the [Tool] menu, the dialog as shown in Fig. 49 is shown. MR3 uses Apache Jena’s validation API (org.apache.jena.reasoner.ValidityReport ) and it is enabled to check if the data type of literals are defined based on a range of property.

Validator

Fig. 49 Validator

Project Info

When the users select [Project Info] sub menu in the [Tool] menu, the dialog as shown in Fig. 50 is shown. The current project name, the number of RDF resources, the number of RDF literals, the number of RDF statements, the number of classes, the number of properties, the number of all resources, the number of all literals, the number of all statements are shown in the dialog.

Project Info

Fig. 50 Project Info

Log Console

When the users select Show [Log Console] sub menu in the [Tool] menu, the dialog as shown in Fig. 51 is shown. The users can confirm the standard output and the standard error in the dialog.

Log Console

Fig. 51 Log Console

About MR^3

When the users select About [MR^3] sub menu in the [Help] menu, the dialog as shown in Fig. 52 is shown. The developer, version, license, project web site, contact, and libraries used in MR3 are shown in the dialog.

About MR3

Fig. 52 About MR^3

Toolbar

Icon Function
_images/new.png
New MR3 project
_images/open.png
Open MR3 project file
_images/save.png
Save MR3 project file
_images/saveas.png
Save as MR3 project file
_images/find.png
Show Resource Search Dialog
_images/rdf_editor1.png
Show RDF Editor Overview to the front
_images/class_editor1.png
Show Class Editor Overview to the fornt
_images/property_editor1.png
Show Property Editor Overview to the front
_images/attribute_dialog.png
Show Attribute Dialog to the front
_images/namespace_table.png
Show Namespace Table to the front
_images/cpr.png
Show Class, Property, and RDF editors
_images/cr.png
Show Class and RDF editors
_images/pr.png
Show Property and RDF editors
_images/code.png
Show RDF source codes
_images/accept.png
Validate RDFs contents
_images/information.png
Show Project Information
_images/log_console1.png
Show Log Console
_images/cog.png
Show Option Dialog
_images/help.png
Show about MR3

Shortcut keys

Shortcut keys that can be used in MR3

Shortcut keys Description
Ctrl + N | Command + N Create new MR3 project. The users should select save the current project or delete it.
Ctrl + O | Command + O Open MR3 project file.
Ctrl + S | Command + S Save MR3 project file.
Ctrl + Shift + S | Command + Shift + S Save as MR3 project file.
Ctrl + Q | Command + Q Quit MR3 .
Ctrl + Shift + A | Command + Shift + A Show the Attribute Dialog.
Ctrl + Shift + N | Command + Shift + N Show the Namespace Table.
Ctrl + 1 | Command + 1 Show Class, Property, and RDF editors.
Ctrl + 2 | Command + 2 Show Class and RDF editors.
Ctrl + 3 | Command + 3 Show Property and RDF editors.
Ctrl + R | Command + R Show the RDF source code viewer.
Ctrl + F | Command + F Show the Find Resource Dialog.
Ctrl + Shift + V | Command + Shift + V Validate RDF graphs.
Ctrl + Shift + M | Command + Shift + M Show the Project Information dialog.
Ctrl + Shift + L | Command + Shift + L Show the Log console.
Ctrl + Shift + O | Command + Shift + O Show the Option dialog.
F1 Show about MR3 .

Shortcut keys that can be used in editors

Shortcut key Description
Ctrl + I | Command + I Insert an resource.
Ctrl + L | Command + L Insert a literal.
Ctrl + A | Command + A Select all of the nodes in a editor.
Delete Delete selected nodes in a editor.
Ctrl + C | Command + C Copy selected nodes in a editor.
Ctrl + X | Command + X Cut selected nodes in a editor.
Ctrl + V | Command + V Paste nodes that are copied or cut.